“There has been a signature failure” Error after Restoring an IBM or Lenovo System
Problem:
After restoring an image to an IBM or Lenovo system and booting the computer, the system does one of the following:
- Hangs on a blank screen with a blinking text cursor in the top left corner.
- Displays the error message: There has been a signature failure
Cause:
Certain IBM and Lenovo systems (e.g. those utilizing Rapid Restore) use a nonstandard MBR, which spans four sectors instead of one. These sectors, the partitioning layout, etc. are validated by a checksum. Restoring an image to the drive causes the checksum to fail, which then causes the system to hang or display the error message.
Solution:
The custom MBR code needs to be replaced with standard MBR code:
- Select the Write standard MBR Code option when restoring the image. This will write a standard version of the MBR code to the drive, replacing the broken custom code and allow the system to boot to the active partition.
Note that it's important to make sure the correct partition is set active. This is usually the Windows partition, but may vary depending on how the system has been configured. You may need to select the Set Active option when restoring a partition image. If necessary, the partition's active status can also be changed after the restore using a partitioning program (e.g. BootIt Bare Metal).
- If desired (and depending on the system), Rapid Restore may be able to be reactivated via the Control Panel in Windows. Otherwise, using Rapid Restore will no longer be an option when booting.
Technical Notes:
When the original drive is imaged in its entirety and restored in its entirety back to the original drive, the custom MBR should still function correctly. However, restoring to a different drive or even to the original drive using different geometry will cause the failure.