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“BOOTMGR is missing” Error When Attempting to Boot into Windows

Problem:

When attempting to boot into a Windows Vista or Windows 7, Windows fails to load. Instead, the following error message is displayed:

BOOTMGR is missing
Press Ctrl-Alt-Del to restart

This may happen after making partition changes or after restoring the Windows partition.

Cause:

The files necessary to boot Windows were not found on the partition booted. These files include the bootmgr file and the \Boot folder (which contains the BCD file).

This can be the result of the wrong partition being set active or that the booting files do not exist on the partition.

Windows will install the booting files to the active partition on the booting drive. This partition may or may not be the selected Windows installation partition. For example, if Windows XP is already installed and you then install Windows Vista/Windows 7, the new installation will place its booting files on the XP partition. If you later delete the XP partition or backup the Windows Vista/Windows 7 partition and restore it to another location (such as another drive) and then attempt to boot it, it will not boot since it does not contain the necessary boot files.

Solution:

If partitioning changes were made, verify that the correct partition is set active. This can be done using BootIt BM and looking at the MBR or by editing the boot menu entry for Windows Vista/Windows 7 and making sure the correct partition is selected as the booting partition. If necessary, see Note C (below) for instructions on using DISKPART to set the partition active.

If BootIt BM is not being used and the Windows partition was restored to a primary partition, verify that the partition was restored as an active partition. This option can be found in Image for Windows, Image for Linux, and Image for DOS (Set Active). If you restored to a logical partition, please see Note A (below).

For Windows Vista and Windows 7 installations on an active primary partition, the booting files can be replaced or updated by using the Windows installation DVD or the Windows 7 System Repair Disc. Note: If using the installation DVD, a standard Microsoft OEM or retail version is recommended. Brand-name discs may not provide the same repair options.

In the instructions below, "Repair Disc" is used to reference the repair media. For Windows 7, this will be either the Windows 7 installation DVD or the System Repair Disc. For Windows Vista, this will be a Windows Vista installation DVD or one of the Windows 7 discs. Any specific differences between the discs are noted in the instructions.

Instructions:

  1. Verify the Windows partition is set active. Note: If the wrong partition is set active, the Windows repair will unable to complete successfully. If necessary, see Note C below for instructions on using DISKPART to set the partition active.

  2. Insert the Repair Disc into the CD/DVD drive and reboot the computer. Note: If the computer is not configured to boot the CD/DVD drive before the hard drive, you may need to change the boot order in the BIOS.

  3. When the message Press any key to boot from CD or DVD... appears, press a key to allow the Repair Disc to boot.

  4. Select the desired language and keyboard layout you want to use and then click the Next button.

  5. If using a Windows installation DVD, click the Repair your computer link in the bottom-left corner of the window.

  6. System Recovery Options will scan for Windows installations. It should report the following:
    Windows found problems with your computer's startup options.
    Do you want to apply repairs and restart your computer?


    Click the Repair and restart button.

  7. The computer will reboot. Repeat Steps 3 through 5 to return to the System Recovery Options screen.

  8. After System Recovery Options completes its scan this time, the Windows installation requiring the repair should be displayed in the list of operating systems. Normally, it is selected. If it's not, click it to select it. Note: If using a Windows 7 DVD or System Repair Disc, also make sure the Use recovery tools that can help fix problems starting Windows... option is selected.

  9. Click the Next button. The Choose a recovery tool window should be displayed.

  10. Click the Startup Repair link. The system will be scanned and repairs will be attempted (it should only take a few seconds).

  11. Click the Finish button.

  12. This time, do not press a key to allow the Repair Disc to boot. Instead, allow Windows to try and boot. If the repairs were successful, Windows should boot normally.

Technical Notes:

Note A - Windows Partition Restored to a Logical Partition

The automatic Windows boot repair procedures will not work on a logical partition as Windows won't see it as bootable. In this case, the files will need to be manually copied onto the Windows partition (see Note B). Also, to boot Windows from a logical partition you must use a boot manager that supports it (such as BootIt BM). The standard Windows boot manager won't boot Windows from a logical partition.

 

Note B - Manually Copying the Booting Files:

If the partition that contains the booting files is available and the automatic repair method using the Repair Disc won't work, the files can be manually copied to the Windows partition. In this example, E: is assigned to the partition containing the booting files and C: is assigned to the partition that needs the files.

  1. Boot to the Repair Disc and enter the Repair Mode (reference Steps 2 though 5 above, if necessary).

  2. Cancel any automatic repair attempts to return to the System Recovery Options window. If using a Windows 7 DVD or System Repair Disc, make sure the Use recovery tools that can help fix problems starting Windows... option is selected.

  3. Click the Next button. The Choose a recovery tool window should be displayed.

  4. Click the Command Prompt link. The Command Prompt window will open.

  5. Copy the bootmgr file from the source partition (E:) to the destination partition (C:). Make sure to use the drive letters as assigned on your computer. Run the following command:
    robocopy  e:\  c:\  bootmgr

  6. Copy the Boot folder. Run the following command:
    robocopy  e:\Boot  C:\Boot  /s

  7. The booting files have now been copied. If you wish to verify that they were copied correctly, run the following command:
    dir  c:\  /ah

    If the bootmgr file and the Boot folder show up in the list, the procedure was successful.

After the files are copied, the BCD file must be updated to point to the correct partition. This can be done easily using the BCD Edit capability in BootIt BM (How to Use the BCD Edit Feature of BootIt BM). If BootIt BM is not being used or you wish to update the BCD file manually, run the following commands while still in the Repair Mode Command Prompt of the Repair Disc:

  • bcdedit  /store  c:\boot\bcd  /set  {default}  device  partition=c:
  • bcdedit  /store  c:\boot\bcd  /set  {default}  osdevice  partition=c:
  • bcdedit  /store  c:\boot\bcd  /set  {bootmgr}  device  partition=c:
  • bcdedit  /store  c:\boot\bcd  /set  {memdiag}  device  partition=c:

As in the example above, C: is used as the drive letter assigned to the partition containing the copied BCD file. Make sure to use the correct drive letter for your system.

 

Note C - Using DISKPART to Set the Windows Partition Active:

If you are not using BootIt BM, DISKPART can be used from the Repair Disc to set the Windows partition active.

  1. Boot to the Repair Disc and run the Command Prompt (reference Steps 1 though 4 in Note B, if necessary).

  2. Start DISKPART by running the following command:
    diskpart

  3. DISKPART will start and you will be at the "DISKPART>" prompt.

  4. List the drives by running the following command:
    list disk

  5. The installed drives will be listed, starting with Disk 0. In most cases, Disk 0 is the booting drive and also the drive containing the booting partition. You need to select the drive that contains the partition which needs to be set active. In this example, that is Disk 0. Select the appropriate drive by running the following command:
    select disk 0

  6. The next step is to select the partition. To see the list of partitions on the drive, run the following command:
    list partition

  7. Select the partition which needs to be set active. In this example, Partition 2 is the desired partition.
    select partition 2

  8. Set the selected partition active by running the following command:
    active

  9. Finally, exit DISKPART:
    exit

 

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